Kaseya Community

Remote control connecting to wrong server?

  • Remote control works just fine for 30+ servers but when I try to connect to one particular one, I get a different machine (different customer/network). Has anyone had this issue and how do I resolve it?

    Legacy Forum Name: Remote control connecting to wrong server?,
    Legacy Posted By Username: masselin
  • Hey Masselin,

    Just curious. Is it Remote Desktop or VNC you are using to connect to the servers and are the servers Windows 2008? If it's Remote Desktop the RDP connection to 2008 servers remembers the previously used credentials to the previous server you controlled e.g. you control one site as SITE1\Administrator and then you go to control a different sites 2008 server it uses SITE1\Administrator as the credential and lists that domain as the one you are connecting to. Makes it look like your controlling the wrong server but might not be the case...

    Hope that helps!

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Alan_R
  • Remote Desktop and server 2008 - mystery solved. I knew it was something simple that I was missing completely. Thank you.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: masselin
  • I found this to be very frustrating, and after some digging found the info below and sent it to all my techs. Hope it helps.

    In case you are annoyed as I am that RDP caches the last domain you connected to on 2008 servers, which is then incorrect the next time you RDP to a different client’s server, I’ve found a fix. The reason this happens is that RDP 6.x caches a “username hint” for each IP or server name you connect to. In most cases this would be a good thing, however because of how Kaseya makes the RDP connection, you may have noticed in the top bar on the RDP screen that your PC thinks it’s connecting to 127.0.0.1 no matter which Kaseya agent you connect to. That is why the wrong domain\user name pops up for Vista and Server 2008, unless you’re connecting back to the same server you were just on.

    To fix the problem, on your own PC go to the registry key HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers\127.0.0.1, and then set permissions on the UsernameHint string value to Deny yourself Read access to it. As soon as you do this, you should start seeing the right domain name when RDPing to 2008 servers.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: kcears
  • Brilliant!!!! Big Smile Big Smile Big Smile

    I've been cursing 2008 for the very thing and having to remember all my clients' domains. Now I can get a little bit of brain space back.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: CCDave
  • Wonderful! Thank you very much kcears. Big Smile

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: masselin
  • How to fix Cached Credentials for remote control.pdf

    I've attached instructions for manually setting the deny option.

     

    I was trying to script it with regini.exe, but ran into issues with programatically retrieving the "current user" registry entry since it is really just a link to the location under hkey_users\[user_sid]. It wasn't worth the effort since I was able to make the how-to so quickly.

  • How to fix Cached Credentials for remote control.pdf

    I've attached instructions for manually setting the deny option.

     

    I was trying to script it with regini.exe, but ran into issues with programatically retrieving the "current user" registry entry since it is really just a link to the location under hkey_users\[user_sid]. It wasn't worth the effort since I was able to make the how-to so quickly.