Kaseya Community

Monitoring Returns Same Value

  • After adding a monitor & checking the monitoring log the value returned for all counters checked is -998. Some servers are returning values fine. Some only show this. Has anyone encountered this and what was your fix ? tks

    Don Fievet

    Legacy Forum Name: Monitoring Returns Same Value,
    Legacy Posted By Username: dfievet
  • Typically you will get this sort of behavour if the perfomance counter:-

    1) doesnt exist on that machine
    2) Hasnt generated a value yet

    If you look at the counter with Perfmon do you get a null value on those machines?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: PeterS
  • Also, if you applied this monitor to a 2008/2008R2 server, check to make sure your performance counters are actually running. (Not the service, the actual counters.) You can see the counters Kaseya installs by going to Computer Management and looking under Performance Logs and Alerts. All Kaseya counters start with KCTR$.

    I've found that in 2008/2008R2 there is an option in the counters to overwrite or not overwrite the current file. Sometimes it is not selected to overwrite and you will get a "file exists, cannot overwrite" error when you try and manually start the counter.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: CCDave
  • There are no null values in Perfmon when I log into the server & run it. It registers values. It's a 2003 server. I've deleted the monitor & readded it. Clicked the Update Lists by Scan. Clicked the re-apply counter & checked to make sure the temp dir is c:\kaseya. Some servers work perfectly returning values up & down the counters some just show all -998.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: dfievet
  • I am seeing the same problem, we recently upgraded to v6 and since then multiple counters won't respond anything except -901. Those same counters load fine and give reasonable, non-negative values in perfmon.

    I have a ticket in with support, will keep you posted.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: John Salle
  • Response from Kaseya support:


    We have found a problem in the code that would have caused this.

    We have fixed and it will be coming out in our next release in the next few days.

    Aaron


    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: John Salle
  • I am also having the issues with -901 being retured on my monitoring sets. Anybody know if this has been fixed yet?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: kswanda