Kaseya Community

VNC Viewer Error

  • I am runnning Vista SP1, an attempt to connect to remote machines using vnc/k-vnc and receive the following error; RegOpenKeyEx: Access is denied (5) I am looking for a KB to help me troubleshoot this further.

    Legacy Forum Name: VNC Viewer Error,
    Legacy Posted By Username: atlantec
  • The very first time you try to remote controll a machine on vista you need to launch internet explorer by right clicking on the IE icon and selecting run as administrator. Then connect to your Kaseya server and launch a VNC session as normal.Once you've done this once then you should be able to run IE normally in the future (although I find it forgets occasionally perhaps as patches are released)

    Same is needed for ftp

    regards

    Nick

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: nviner
  • Thanks for replying, that worked.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: atlantec
  • SYMPTOM
    Error when trying to start VNC session from Vista - "RegCreateKeyEx: Access is denied. (5)"


    CAUSE
    The remote control components and ActiveX control (kasRmtHlp class) requires elevated administrator privileges to install from within the browser on the Vista box on which the administrator is initiating the remote control session.


    RESOLUTION
    To complete the installation successfully through the browser, without needing to install VNC, launch a web browser by right mouse clicking on the IE7 icon and select "Run as administrator" from the popup men. Starting it this way will give that instance of IE7 the rights to needed by the ActiveX contrl to create the registry settings for the VNC viewer. The remote control session should then run as it would on any other Windows OS.

    Subsequent remote control sessions can then be run from a browser launched normally (i.e. without the "Run as administrator") after the registry settings have been made.


    APPLIES TO
    Remote Control

    Thanks

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: gopinath.jayakumar
  • Just wondering if anyone else running Win7 is having this issue everytime they run the VNC client? This is my second install of Win7 and still have the issue, so supect it's not a one off exceptional configuration.

    I ran the VNC client as administrator first, as I did with Vista, but I still get the RegKeyOpenEx error after every reboot, and have to launch it at least once as admin. Subsequent connections are okay as normal user, until it's rebooted again when the problem reappears.

    Really annoying, and I don't really want to turn UAC off completely (which does fix it)

    Cheers
    Lee

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: leeevans