Kaseya Community

Setting File Source location?

  • Has anyone had any issues setting the file source on the agent that is hosting the share for the file source? I've done this with several of our clients and never seemed to have an issue. However, last night I scheduled installs for KES and BUDR on an agent that is hosting the file source share and has the file source configured. I made sure a reboot occurred between the installs. Both of the installations failed. It looks like they failed because the package was not fully downloaded to the file source before the installation kicked off.

    Legacy Forum Name: Setting File Source location?,
    Legacy Posted By Username: SteveR
  • How fast is the internet connection?

    Downloads are treated as scripts and if I remember right any script that has been running for more than 2 hours is automatically stopped.

    If it is a really slow connection I can see the BUDR installation taking longer than 2 hours, the installer is 157 megabytes.

    Also, try switching the file source to internet and do the installations, I am curious if you get a different result.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: jcourtney
  • Yes i have had the same issues.

    When the file source is configured to a local server, the machine that is the local server needs to download the applications and patches etc from the K Server.

    I have had issues with the machines on the network failing with BUDR installs when the file source is set to a local server, because that local server has not downloaded the install package etc from the K Server.

    Kaseya seem to not want to admit the problem exists.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Commander
  • What do the various K logs show for both of you? Do you find remnants of the installer package sitting on these agents?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: ReedMikel
  • The BUDR failed with:

    FAILED in processing THEN step 19, Get Variable, with error Registry Query Failed, Registry Value = HKEY_LOCAL_MACHINE\Software\Acronis\TrueImageServer\Settings\WorkingDir


    KES failed with:

    FAILED in processing THEN step 4, Execute Agent DLL Function, with error Spawn Failed



    There were no leftovers from the install packages. Looks like it never got to to the point of actually installing the software. It installed without a hitch once I changed the file source to pull from the internet.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: SteveR
  • Its been too long since the last time I had this issue, the logs are long gone.

    I did manage to find a KB article regarding the two hour time limit on scripts.

    http://kb.kaseya.com/display/2n/articleDirect/index.asp?aid=279396&r=0.1241114

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: jcourtney
  • Ahhh, the good old cryptic K logs Smile
    If it's reproducible, why not submit a ticket to K? Or have you?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: ReedMikel