Kaseya Community

Credential Woes

  • Hello Kaseya User Community :-)

    I'm not sure which category to put this in, so General it goes:

    The issue I am seeing is when I try to set credentials on some systems, but not all, they always fail to pass the credential test. There is a script that we use here that creates a local admin account on any machine we push the script to. I push the script and it appears to complete successfully, but every time I set the credentials in the credential test and test again it fails. On the Kaseya KB I found article 286913 which states the following:

    # SYMPTOM
    1 agent will not pass credential test under Agent tab > Set Credential. Errors generated in agent log : -

    ERROR: getVariableValue() failed to get dynamic script variable value, type 1 - c:\\credentialTest.txt.
    ERROR: doGetVariableValue() failed to open c:\\credentialTest.txt

    Tried both local and domain accounts, tried creating new account. Tried reinstalling agent, verified no host based firewall, restrictive GP etc.

    All other machines on this domain pass credential fine.


    # CAUSE
    Problem with machine's security policies/permissions

    # RESOLUTION
    Reset the machine's security policies/permissions to default using the following command: -

    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

    # APPLIES TO
    Kaseya Agent

    MS Windows


    So, I go ahead and script this and push it to the machine that I'm having an issue with, it runs successfully and I'm STILL getting the same results. Failed credential tests and still getting errors in the log. Any suggestions?

    Eric

    Legacy Forum Name: Credential Woes,
    Legacy Posted By Username: TSI-Eric
  • Go to the C:\Temp folder, go to Security, and get rid of the "Allow inheritable permissions from parent" nonsense. Then adjust the permissions so that Administrators and System have full control.

    Give the test another shot.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: pbish@eresources.com
  • Confused
    I am having a problem with Set Credential as well. This server has been working fine for months then last week I get an error during the patching that the credential is invalid. In the Set Credential function, I am specifying the correct user/domain/pass. I have tried resetting the security template and also adjusted security on the temp directory. I have also uninstalled/reinistalled the agent.
    I am not sure if this is related, but the Kaseya service won't start if the "allow service to interact with desktop" option is checked. If I uncheck it, the service starts.
    If anyone can help me, I would greatly appreciate it!

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: BradE
  • make sure that the local admin account you are using does not have an expired password. I ran into a similar problem. There is a script on this forum that will allow you to make any account have a non expiring password.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: jrahmani
  • I'm still fighting this issue.
    I have removed and reinstalled the agent multiple times, have tried using multiple accounts (all with domain admin privileges). I have checked permissions on temp directories and the agent directories.
    This has been running fine for months and I can't understand what has happened all of the sudden.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: BradE
  • Hello all.

    It was suggested to us at the Kaseya Connect conference that we create a user, specific to our firm, that will be used for the credential on all machines. I got a script from Kaseya that creates a local user as an administrator, sets the password, and then it hides the user from the fast user switching selection screen.

    It worked on half of my machines, though the script says "success" for all. On one of the machines on which it failed, I tried to go into remote control, and reset password on it, and it failed THEN in step 1.

    I'm really kind of frustrated with the set credentials at this point, and not sure what to do.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Matt.Conlon
  • What OS is having the problem. Does it seem to be happening to a particular OS, like Vista, more often?

    For vista I have found that the step in the script that runs the net user /add command needs to be run as the system and not user.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: mwolter
  • I think I have a similar issue if not identical,;
    3 systems on a network but not part of a domain, all have been working great up till just lately. They all connect to a nas box for backups and data storage.

    Now 1 system fails backup due to failing credential test, resetting all the permissions with
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    worked great until I realised the printer attached was no longer shared to the other 2 PC's, so I reshared it and now the credential test fails constantly again. Obviously its a securities issue, but why would sharing a printer affect what the pc is able to access or affect the credentials?

    There is no server, just the nas box, all the systems have the same credentials, and backup to the same location. Only 1 has a shared printer, and is the one that fail the test. They are all XP pro.

    The credential used is one we created on each pc as an administrator account.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: george