Kaseya Community

VSA Web API does not work

  • I have moved my kserver to a faster box. It now runs on Windows2003 x64 and SQL2005 x64.
    All seems to be going well from the speed side of things.

    We use AutoTask for ticketing and have kaseya email tickets to AutoTask. AutoTask used to work just fine with the old system but now it has problems. Every time kaseya generates an alert to be forwarded to AutoTask it sends an email back to me with the following information:

    The request failed with HTTP status 405: Method Not Allowed.

    I have been into Kaseya VSA, System | Configure and unchecked then re-checked the Enable VSA API Web Service checkbox.
    But still have the problem.

    I have run the KaseyaWStestClient.exe program and it also has the same error

    The request failed with HTTP status 405: Method Not Allowed

    When I run this KaseyaWStestClient.exe against the old machine it returns a valid session id.

    I am not sure where to go from here??

    Our kaseya generated tickets are not being forwarded to our ticketing system.

    I have logged a ticket with kaseya support but thought I would also ask the forum.

    Legacy Forum Name: VSA Web API does not work,
    Legacy Posted By Username: garry
  • I am a little lost. VSA web service is needed to send emails to autotask? I don't use autotask so i am unfamiliar with the setup.

    To verify the VSA web service is running, go to the following url:

    http(s):///vsaws/kaseyaws.asmx

    If you get a web page displaying the different functions available, then the VSA Web Service is running. Otherwise you would probably get an error.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: boostmr2
  • VSAWS is not needed to log tickets into AutoTask. These are sent via email to AutoTasks "addticket" account.

    When we enter anything into the ticket in AutoTask it sends the info to Kaseya via VSAWS. In my case, this was giving me errors.

    Your method of checking VSAWS is a good one.
    http(s):///vsaws/kaseyaws.asmx
    This failed for us.

    VSAWS now works for us. Here are the steps Kaseya Support used.

    Yes I did get you running. This problem can occur due to sequences of installations. The relationship between .NET frameworks and the IIS configuration can get whacked. You can save the following lines in a .bat file for future use:

    rem Register-Only Install of the framework, enabling extensions

    %windir%\microsoft.net\Framework\v2.0.50727\aspnet_regiis -ir -enable

    rem Remove any previous scriptmaps from the vsaWS web service

    %windir%\microsoft.net\Framework\v2.0.50727\aspnet_regiis -k W3SVC/1/ROOT/vsaWS

    rem Install scriptmaps for the vsaWS web service, recursively

    %windir%\microsoft.net\Framework\v2.0.50727\aspnet_regiis -s W3SVC/1/ROOT/vsaWS


    All is well now.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: garry