Kaseya Community

VNC Viewer Error

  • We get the error "RegOpenKeyEx: Access is denied" using Vista to connect to clients. Running IE as administrator seems to help. Any ideas? It doesn't happen all the time.

    Legacy Forum Name: VNC Viewer Error,
    Legacy Posted By Username: runnetworks
  • I suspect that you have UAC turned on, as I had exactly this problem. I turned UAC off on my Vista laptop (for reasons other than Kaseya) and the VNC problem went away.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: PeterS
  • That would make sense. The problem has gone away for me, probably since I disabled UAC. Another user still has the problem every now and again. I'll make sure he disables it.

    Thanks.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: runnetworks
  • On vista I believe you have to run the remote the first time as administrator only to allow it to set the registry key. After that I don't think it's required.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: doug.jenkins@ispire.ca
  • Running IE as administrator and installing the activex control always has worked for me.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: smbtechnology
  • That's why I thought it was a strange issue. I ran it the first time as administrator, installed the activeX control. That was no surprise. Then I used it for a few days and got the error again. Then I ran it as administrator again and it worked. Maybe there was a hotfix that was released and it reinstalled the plugin. The same thing happened to another admin.

    Do you guys all have UAC disabled?

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: runnetworks