Kaseya Community

Initial Update issues.

  • Hi everyone,

    I'm currently trying to security patch everything on a client's network due to some security related issues we have encountered in the last week.

    The issue I'm running into is some machines have very few patches installed. Assuming the logical thing to do would be to run an initial update on these machines overnight, this is what I have done.

    2 days later, these machines are still showing; Initial Update processing non-security patches at .

    I have tried rescanning these machines etc to reset this status, but no luck.

    Further to this, the machines are still lacking the patches and considering the size of them, I imagine that there has to be at least a few security patches in there.

    Any ideas on what I can do to resolve this?

    Cheers

    Legacy Forum Name: Initial Update issues.,
    Legacy Posted By Username: LANWorx
  • Verify credential, patch location, etc.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: rwitt
  • Initial update, to be blunt, sucks. The issue is that if for any reason the script gets interrupted, the K Server doesn't know that, and does not complete the updates. We run a temp directory cleanup script each night that clears out the files of the agent temp directory. But the inital update XML and status files were in there, so when they went away, the initial update failed. K Server didn't notice, it just keep looking for the next status to execute so it could deploy more patches... But that next status will never come.

    What you should do is go to the initial update screen and cancel it. Re-deploy it, and it'll pick up where it left off. If something keeps killing it though, you may have to do this a few times before the PC is totally updated.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: arobar
  • Verifying the credential and patch location is the first thing I had tried.

    Alex, I'll give your suggestion a shot. Thanks a bunch for helping with this!

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: LANWorx
  • Initial Update is a one-time processing of all approved Microsoft patches applicable to a managed machine based on Patch Policy. Have you check your patch policy list? If i am not mistaken, Initial update will only install patches for approved policy that we declared on Approval by Policy function list. It will not install for pending approval patches.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: tesvin
  • You're right, it will only install the patches that are approved by policy. But if that were the problem the PCs wouldn't still say "processing" for their initial update status. If there's nothing to install for a given group, the PC reboots and moves onto the next group, and will eventually report that all updates were applied.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: arobar
  • Arobar, you were completely correct, this solved the issue entirely!

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: LANWorx