Kaseya Community

Kaseya\Connectwise Integration broke from installer

  • In light of the previous news releases about the vulnerability to kaseya server from the Connectwise Managed Sync app, we have been using the newer re-released update and also IP lock down to only the connectwise server and the site was not public facing (we ran all the test modules and showed as not vulnerable).

    During the pre-req check form KInstall, it ran a "Disable Insecure Connectwise Integrations; This fix-it disables insecure integrations with the VSA" (which it stated was installed, and then fixed it). It is now completely broken and wont sync.

    We have always had kaseya sync to connectwise, and we also use IT Glue which syncs from\to Connectwise and from Kaseya directly. So new agent in Kaseya->New Config in connectwise->new config in IT Glue

    IT Glue will pull the kaseya agents into it, but wont sync them back to Connectwise unless each new config is opened and re-saved (very unproductive)

    Is anyone else using any other type of synchronization to get kaseya machines into connectwise

  • I upgraded from a few days ago and it didn't call out the fix-it you mention, just upgraded without issue. When I'm back in the office I'll check the CW sync is still working as you've got me spooked now! ;)

  • We use MSPAssist to cover the integration between CW and Kaseya - it does not require the CW integration.  I did see the popup that you mentioned though despite the app-pool/service not being active.  It looks as though Kaseya is just double checking that the service/app-pool is either completely patched or inactivated if it is not up-to-date.

  • We also use MSPAssist but i did not think MSPAssist syncs configs? We were using the integration to sync our configs from Kaseya to CW.

    We don't have the problem you mention with ITGlue, ITGlue syncs back to CW without that issue you are expirencing. You may want to open a ticket with ITGlue support.

  • Tim and Corey, thank you for the information.

    I have reached out to MSPAssist to get this up and running.

    The issue with IT Glue (confirmed with them) is if you have the kaseya sync directly to ITG.

    Those new workstation\server configs created in ITG will not go back to Connectwise. You would need to open the config and re-save it (not happening)

    ITG recommend RMM to PSA then to ITG (which is what you seems to be doing with MSPAssist syncing kaseya to connectwise, then connectwise to ITG.

    All of our normal adds in ITG go back no issue to Connectwise and vice versa

    Since we lost the connectwise integration sycn from kaseya, once we get MSPA setup we should  be golden again.

  • "i did not think MSPAssist syncs configs?" it works with a procedure that runs on the endpoint and reports back.  MSPAssist is working on making it bidirectional and also the ability to tie the configurations to an agreement.

  • We use the CW 'managed sync' application, not MSPAssist and I've confirmed our sync setup is still working fine following the update.

    For us at least there was no 'warning' during the update process. We had applied the fixed version of the CW 'managed sync' application (and performed the IP lockdown, etc) some time ago.

  • Still never got a direct answer from MSP Assist yet, or spoken to them yet. Just a few emails back and forth

    I was able to get the KServer-CW sync application back up. Had to restore the c:\program files(x86)connectwise folder to the kaseya server. When I reinstalled the KaseyaMSP executable, it only created c:\program files\connectwise folders which it wouldnt recognize. Then Re-targeted the IIS Application Web Site to point to the x86 folder and then the kaseyacwwebservice/ManagedIT.asmx came up right away.

    We still have an issue that the Sync wont start (even manually) so i have CW Support looking at it.

  • Does everyone still have this integration working because I am still waiting for the Connectwise 'devs' to fix a 'known issue'. We don't use MSP assist.  However, Connectwise never explained what the known issue was.  This has been broke for over a month for us so just wanted to check if we were the only ones.

    Again, coming up on month end and still broke.

  • Ours has been working and never broken...We had applied the security update when it originally came out, and just to be safe I applied the new one that came out a month or so ago even though ours tested as not having an issue. I applied the .19 Kaseya update Tuesday night and I didn't get any issues, and I just verified our Machine syncing is still working fine.

  • Ours is still working, and have reapplied .19 a few times to ensure nothing breaks.


    You should not have the c:\Program Files (x86)\connectwise\ folder present on the Kaseya Server, as the newest connector only uses the x64 version at C:\Program Files\ConnectWise\ and the IIS website points to that 64 bit folder

    The most important thing is making sure the key.json file is generated from the Connectwise Manage (Management IT\Kaseya options) and added to the c:\program files\connectwise\ folder (that also has the KaseyaCwWebService website folder in it)

    Ensure the IP restriction is added on the KaseyaCwWebService website and locked down to the and the IP address of he Connectwise Server.

    You shouldn't be able to browse externally to https://KaseyaPublicUrl/KaseyaCwWebService\ManagedIT.asmx as that should be locked down to internal only

  • Hi Adam,

    We have been experiencing the issue similar to @GDRBrian for 2 months now. We reinstalled the ManagedITSync multiple times, re-saved the key.json, adjusted the web.config to point to the correct location (there is no x86) and even without the IP restrictions, the Kaseya Server will not load the webpage and instead says

    "Oops. Something went wrong.

    The issue may be temporary. Please go back and try again. If the problem persists, please get in touch with our friendly support team. We're here to help."

    with the URL being


    I believe this is because the Kaseya Firewall / SSL Cert is re-written to a different port and is not on 443. This is hte same error and URL response that we get on either the Kaseya Server direct, the ConnectWise Server, or any other device on our network.

    I've had a ticket open with ConnectWise for 2 months and they are no closer it seems to solving it than day 1 when it was submitted.

    We're on .19 and not have not yet updated to .20. During the install of .18 / .19 (We had upgraded to /18, had the issue with < 2003 agents, then upgraded to .19 when available) we had never had the pop-up to disable Insecure Applications.

    Any help is greatly appreciated here as a big part of our day to day is installing new agents and pulling configs / asset Tags into ConnectWise that we manage for Audits and thats been broken since early February.

  • What happens if you just go straight to http://localhost/KaseyaCwWebservice/ManagedIT.asmx

    From the Desktop of Kaseya server itself.

  • I should point out that I get the *exact* same error if I try to go browse to http://localhost:18081/KaseyaCWWebService/ManagedIT.asmx

    However going to http://localhost/KaseyaCWWebService/ManagedIT.asmx  Instead simply gives me "Bad Request" in the browser.

    Which honestly is to be expected.  You can no longer test it in the browser.  The addition of that json public Key prevents you being able to test it in the browser.  You can't even really test it with the "test" button in Connectwise Manage.

    The only real way to test it is to to run the integration from the Connectwise Manage server by going to the Management Setup table and clicking the "Sync Now" button, and then look at the log file that it generates, after it's done, (available on that same page in Manage).

    In mine that's working for example it shows the following (santized) information as the top few lines of the file which indicate pretty clearly that it's working.  If it's *not* working there should be some kind of error message here, that should be helpful at least to Connectwise support in figuring out what's going on.

    03:00:03: ManagedItSync - Company Name: <myCompanyHere>

    03:00:04: ManagedItSync - Attempting to determine version of Kaseya installed at: http://<myvsaHost>/KaseyaCWWebService/ManagedIT.asmx

    03:00:04: ManagedItSync -


    Managed IT Integration

    Managed IT Setup: Kaseya/K2

    WS Location: http://<myvsaHost>/KaseyaCWWebService/ManagedIT.asmx

    Login Location: https://<myPublicVSAHost>/access/logon.asp


    03:00:10: ManagedItSync - The following machines are new to Kaseya.  Configurations for them have been created in ConnectWise:

    03:00:10: ManagedItSync - 145031447232342 / <machinename1>

    03:00:10: ManagedItSync - 431639507234214 / <machinename2>

    03:00:10: ManagedItSync - 965800603923478 / <machinename3

    03:01:00: ManagedItSync - The ConnectWise configurations for the following machines have been updated:

    03:01:00: ManagedItSync - 101157890623413 / <yetanothermachinename>

  • Hi Jonathan,

    Thanks for the reply. In ours, after doing the entire setup (a few times no less) we are only getting the following. Also, when we try the: http://localhost/KaseyaCWWebService/ManagedIT.asmx it gives us the same "Oops" message but as you said, it's not designed to actually show anything anymore.

    03:12:50: ManagedItSync - Company Name: twc

    03:12:51: ManagedItSync - Attempting to determine version of Kaseya installed at: https://<MyVSA>/KaseyaCWWebService/ManagedIT.asmx

    03:12:51: ManagedItSync - Could not determine version of Kaseya or server error:

    System.Net.WebException: The request failed with the error message:


    <html><head><title>Object moved</title></head><body>

    <h2>Object moved to <a href="/Errors/error.html?aspxerrorpath=/KaseyaCWWebService/ManagedIT.asmx">here</a>.</h2>



      at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

      at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

      at ManagedITSync.MSPKaseyaWebService.ManagedIT.IsKaseya2008()

      at ManagedITSync.ManagementItSetupConnector.getKaseyaConnector(MgmtItSetup setup, IKaseyaWebService ws, IMspApiProxy api, ISimpleLog log)

    03:12:51: ManagedItSync - It is possible that the update scheduled task on your kaseya server stopped working.