I'm running into two problems remotely connecting to a MBP.

The first is a problem with Remote Control not reporting the correct resolution of any of the screens.  The resolutions that are reported on the mac are:

system_profiler SPDisplaysDataType|grep Resolution

          Resolution: 2880 x 1800 Retina  (Remote Control sees this as #2 monitor)

          Resolution: 5120 x 2880 (5K/UHD+ - Ultra High Definition Plus)  (#1 monitor)

          Resolution: 5120 x 2880 (5K/UHD+ - Ultra High Definition Plus)  (#3 monitor)

However, Remote Control reports 2560 x 1440 for the 5k monitors, and 1680 x 1050 instead of 2880 x 1800 for the built-in display.

After connecting with Remote Control, I maximize the Remote Control window.  On the host machine, the monitor I'm using runs at 2560 x 1440.

The first monitor shows up without any problems. I can see the whole thing and interact fine.

If I select #2 (The built-in display of the MBP), I get a mostly grey screen, except for a little rectangle of part of the screen that shows up at the bottom right of the window.  What's odd is it's not even the bottom right section of the screen it's supposed to have captured.

If I select #3, I see only the right half of the captured screen.  The left half still shows the contents from #1.

I'm able to interact with the right half -- sort of.  This screen is running a VM of Ubuntu.  If I click in a terminal and attempt to type an asterisk (*), I can't -- it's like my shift key is broken.  I've tried both shift keys -- sometimes right vs left can make a difference with remote control sessions.

I've tried using KVNC instead, but it doesn't work -- the screen never appears.  Even if I "Preinstall RC", no love.  The mac has no firewall software loaded.

Anyone else run into these kinds of problems and have a workaround?  I need gui access, otherwise I'd just ssh in.