Kaseya Community

Trend Micro VSA plugin

  • Has anyone successfully installed this?  It is failing on 9.2.0.20 so I am wondering if it might only work on 9.3....can't find system requirements for it.

    Thanks

    Ken

  • Nevermind, I updated to 9.2.0.21 this morning and it subsequently installed

  • Hmmm.  I installed 9.2.0.21 before I even tried to install the plugin and mine still didn't work.  I've sent in a request to Trend, but haven't heard anything back yet.  Glad to see at least I'm not the only one having issues with it.

  • Even after it getting installed it won't accept the credentials shown in WFRM....one of my guys is working on that with them now.  Seems kind of like a Beta release

  • Yeah I'm now in exactly the same place.. I've got an open ticket with them as well...

    I re-tried the install again last night after seeing your post and this time it installed, but as you say won't accept the credentials.   If you don't mind sharing your Trend Case #, maybe if we each reference the other's case, they'll realize it's a more widespread issue than just one person.

    My Trend Case # is 00218020

  • Update on my situation at least... They are telling me that the add-in is only supported for customers that you specifically provision through the "LMP" (License Mangement Portal), and not for ones where you specifically purchase the licensing through a distributor or "CSP" customers... Apparently somewhere along the line all of my customers are through "CSP" even though we've been using the license managment portal.  I'm going to have to go through my sales rep to see what we can do to change that...  

  • Hi Karoded, are you still experiencing issues?

  • Did they pull the download for this?  Trying to install a module shouldn't be this difficult.

    I'm on the Remote Manager -> Administration page.

  • Still waiting on Trend....supposedly Sales is trying to add the WFRM link to our LMP account

  • Hi GDR Brian, in order to see the installation package for the plugin in Remote Manager, can you confirm you are using the LMP integrated Remote Manager? If so, after clicking the "Administration page", click "configure third -party integration" link.  From there you will see both the installation package and API creds.

  • Hey Lamon!  how's things?

    Anyway, just to update on my particular situation, after support wasn't really able to help me out other than telling me it had something to do with our licensing, my Channel Manager reached out to me yesterday and he was able to pinpoint the exact issue for me at least. While the download for the Kaseya Plugin and all of the information for the credentails was showing up for me when I logged into Remote Manager, I could never get those credentials to work.   What the Channel Manager was able to pinpoint yesterday is that what I really needed to do was log into the License Management Portal and click the link *there* to go to the Remote Manager console.  In our situation at least for whatever reason we had two separate accounts, one that we use in the LMP and a separate one that we were using to log into the Remote Manager.  When I went through the LMP and clicked *that* link to log into the Worryfree Remote Manager site as the same user I logged into the LMP portal as, then the credentials worked just fine for me.  Of course not all of our customers are showing up under *this* remote manager console, so now I have to figure that out, but I'm one step closer anyway, I now have an activated plugin.

    Now I just have to figure out how to get my other customers migrated over into this remote manager console, and then figure out how to actually *use* the kaseya plugin.  I successfully associated one of the existing companies with one of my machine groups in Kaseya, but all of the agents are showing as "Unmanaged Endpoints".   I'm not really certain at this point what I need to do next, as the documentation is a little thin.  The only option on the Unmanaged Endpoints page is to "deploy agent", but I'm not really sure if that's what I need to do or not, as the machines already have Trend installed on them, and I don't want to re-install trend...  Still researching on that side of things.

  • Hey, Jonathan

    For those endpoints already have WFSS installed, click "deploy agent" won't install it again. The script will first check if WFBSS agent is installed or not, it yes, it will move the endpoint to "Managed" tab, and if not, then it will initial the deployment procedure.

    Hope this answer your question.

  • I am having issues with this as well.  I was able to download the plugin from the Worry-Free console.  But now the console has no links at all to the plug-in, and also no credentials to enter into the plugin to connect Kaseya to Worry-Free.  Under Administration, Tools all I have is this:

    And clicking into "Configure third-party integration" only gives me this:

    I know I saw them there a few weeks ago.  *sigh*  Will try and log a ticket with Trend....

  • Ok.. I just got off a conference call with my Channel Manager, and between the two of us we figured out what is going on in my case at least, and hopefully this can help the rest of you.    Basically we have been using Trend Micro for a long time now, and it *used* to be that you had one sign in for the License Management Portal(LMP) and then a completely separate sign in for the Remote Manager(RM) portal.  So when you add a new customer, you had to add them to the LMP, and then sign in to your RM portal separately and manually "add" the customer there using a unique key that it would generate to let you add additional customers to your view in the Remote Manager.  

    Since then they have integrated the two portals, so that you only really *need* one sign in.  So now if you sign in to the LMP, you'll see a link in the upper right hand corner to the "Trend Micro Remote Manager".  Click that link and it *should* sign you in with the same user as your LMP credentials. If it doesn't for some reason go ahead and enter your LMP credentials. 

    If you use that specific way to access the Remote Manager then the plugin download should be there.  I can verify that *originally* it would also show up if I used my separate RM credentials.  However in that case it wouldn't actually accept any of the credential information in Kaseya once the plugin was installed.  They removed the download link for the plugin from the "non-LMP" remote manager instances sometime in the past couple of days.  In fact I was going to suggest that they do that when I was on this conference call, but when I went to show the channel manager what I was talking about the link was already gone :).

    After using the LMP credentials to access the Remote Manager, I was able get the plugin downloaded, installed, and activated properly.  My next issue was two fold.  

    1.) Not all of my customers were showing up in the Remote Manager when I accessed it from my LMP account. 

    2.) Even for the ones that were showing up in the RM, not all of them were showing up in Kaseya.  

    So working with my Channel Manager, we went through the system and found the issue there.   From the LMP in your customer list you will need to go through each customer, click on the customer name so that it is showing the service plan screen for their licenses.

    On that screen under the "Product/Service:" section there is a checkbox for "Trend Micro Remote Manager".

    For every single one of my customers that didn't show up in either the remote manager or kaseya, this box was *not* checked.  It is checked by default for any new customers that you create, but it may not be checked on any customers you had created before this integrated remote manager was an option.

    Once you have that checked it seems to take about 5-10 minutes for it to really take effect and have the customer show up in both the Remote Manager console and Kaseya, and to be on the safe side I completely closed out of all browser windows and restarted my browser, but then things worked correctly.

    Once you have it up and running it's great to have a single pane of glass to see everything.  The only remaining issue I have at the moment is that the Single Sign on where you are supposed to be able to click the customer name in Kaseya to have it automatically sign you in to Remote manager to manage their Trend Micro settings doesn't appear to be working.  I still have to sign in to Remote Manager.   However once I'm signed in it does take me straight to the correct customer. 

    There also doesn't appear to be a way to *remove* a customer from the Kaseya plugin.  For example I accidentally associated a Trend Customer with the wrong Kaseya Group, and I was unable to find a way to "undo" this.  I had to poke at the database to finally fix that, so don't make any mistakes :).

    Overall for a first go at the Kaseya plugin, I really like it.   I highly recommend looking at Lamon's YouTube Videos here:

    https://www.youtube.com/watch?v=T5GzrX0JkyY

    https://www.youtube.com/watch?v=w98x4XRI5Ik

    https://www.youtube.com/watch?v=ZP6wumXrZEQ