Kaseya Community

Veeam backup and replication add on does not display data

  • Hi

    We are having issues with veeam backup and replication addon for kaseya not displaying data.

    I confirm that the Veeam Data Collection Procedures are running as normal.

    We upgraded kaseya from ver 6.5 to ver 9.2 a month ago and this add on hasn't worked since then.

    Veeam B& R Addon version: 1.1.0.247

    Please help!!

  • I'm guessing there are more 9.1 and 9.2 users having issues. We went from an older 9.1 version to a 2-weekly patch update last September and since then our Veeam reporting has stopped working. Going from 9.1 to 9.2 didn't make a difference.

    A colleague has been looking at reinstalling the Veeam add-on. He is not here right now, so I'll try and check what he's been doing to fix this. I recall him saying something about missing files. Clicking anything in the Veeam module now only gets my errors: Reports show 'Object reference not set to an instance of an object' and the Veeam Dashboard tells me 'Internal Server Error: Arithmetic overflow error converting expression to data type bigint'.

    Kaseya doesn't support this themselves, unless it's clear something in the database is causing this issue. You should consider starting a ticket with the Veeam helpdesk about this issue.

  • We're on 9.2 and recently had issues with the Veeam add-on.  I wasn't involved with support to get it corrected, but I do have these steps forwarded to me from the tech working the ticket.

    If you're comfortable diving in, have fun.

    If not, I'd agree there is an issue and you'll need to work with Veeam support to get it corrected.

    MJ

    Thank you for your time on remote session today. We did several tests to confirm that file transfer works fine. However we decided to re-import AP as PowerShell file transfer steps were not logged properly. We need to follow the steps below in order to re-import Veeam Agent Procedure properly:

    1. in Kaseya VSA navigate to Agent Procedures > Manage Procedures > Schedule/Create and delete "Collect And Process Backup Server Stats" AP

    2. --- then delete empty Veeam Procedures folder

    3. run both SQL queries against ksubscribers database just in case some parts of Veeam AP there. Make sure that the account under which you will run the queries has sa permissions and you have valid db backup as well:

        delete from tree.treeNode where ref in ('Veeam Procedures', 'Collect And Process Backup Server Stats')

        delete from scriptIdTab where scriptName like 'Collect And Process Backup%'

    4. switch back to Kaseya VSA and click "Import Folder/Procedure" and choose CollectAndProcessBackupServerStats.xml file from Veeam Plug-in for Kaseya distribution pack

    5. approve newly imported AP

    6. schedule and run Re-apply schema in Kaseya VSA. Just in case we recommend to re-apply schema during out of business hours.

  • Thanks Mike_Judd. I will try and let you know.

  • Thanks OudjesEric.

    May be you can check with your colleague if his fix had the same steps as posted by Mike below

  • Hi mandeep.s,

    I know this thread is a few months old now but I was wondering if you found a solution? I am seeing the same thing here, Agents installed on Veeam server, AP running without error but no information coming back to VSA.

    Any assistance would be great.

  • Veeam v9 servers? Have you Applied the hotfix to the VSA module? https://www.veeam.com/kb2090

  • SlimChicken,

    I was not able to delete the procedure " "Collect And Process Backup Server Stats"

    So I tried re applying schema multiple times which did the trick.

    @Craig.Hart

    Thanks for the hotfix. Will apply it surely for V9



    typo
    [edited by: mandeep.s at 5:54 PM (GMT -7) on May 9, 2016]
  • I'm getting the error on both the Dashboard and Discovered Machines in the Veeam plug-in:

    "Internal Server Error: Arithmetic overflow error converting expression to data type bigint"

    Note that I do get some data, but Protected VMs Overview and Discovered Machines won't populate any data, just a spinning circle.

    I was seeing this error once I first got the plug-in installed and updated to the latest from Veeam.  I was on R9.4.  So I upgraded VSA to R9.5.  Now I see a different error in GUI (but the same arithmetic overflow error in the Veeam plug-in logs):

    "Internal Server Error: There was an error processing the request."

    I have a ticket open with Veeam - Veeam Support - Case # 03004791

  • Just letting you know we run veeam add-on on 9.5, was upgraded from 9.4, all works fine here for us.

    Arithmetic overflow implies a *huge* number is being read or generated somewhere when doing math. Are your backup sets massive e.g. >10Tb ? also, have you tried resetting your VSA's preferred datetime to mm/dd/yyyy ? - i've seen kaseya fall over with 'oddball' date formats (oddball = something other than US format).