Kaseya Community

R9 - Reviews and Issues

  • Greetings all,

    I thought I'd start up a new thread about R9, similar to the R8 and R7 discussions that we have had previously.

    For us, the transition to R9 was not all that smooth. I'm having the following main issues:

    - Constant KRC connection issues - see https://helpdesk.kaseya.com/entries/88494008-Kaseya-Remote-Control-give-Machine-not-online-error-after-Upgrading-to-R9 

    - kinstall.exe shows a "fix it" post R9 re: application pools; allowing the fix breaks the system and I have to change app pools back manually. Kaseya support can't reproduce the issue and have tried all sorts of things to fix it without success. (R8 was fine). I've allowed them to log onto my VSA to see the issue first hand, and still they can't seem to fix it.

    - many views are broken. Try selecting the "zz[SYS] Agent - Offline" view, for example (Note that machines marked as online are listed!!).

    - KRC logging only logs the FIRST name of the administrator; so if you have a number of admins and their names contain a space character (e.g. John Smith and John Brown), the KRC logs show only "John" as establishing a KRC session --- so which user was it??? Classic RC logs the full name correctly.

    - the dbo.administrators SQL table no longer logs the IP Address of the VSA administrator. We use this table to report on who is logged into the VSA. Fortunately the system log still records VSA user IPs correctly so at least we have a fallback there.

    - EMM you can't onboard a new client if you dont have LDAPS (Secure LDAP/SSL) configured on AD. (By default, AD doesn't have LDAPS enabled). Guess what, however, the 'test connection' check passes anyhow....(it only tests LDAP, not LDAPS) leading to a false indication. Support write this article https://kaseya.zendesk.com/entries/88507087-EMM-Basic-Requirements where they describe the need for SSL - BTW this wasn't a requirement in EMM beta, just something slipped in at the last second. Mind you, securing LDAP comms with SSL is a good idea; it's more the fact that they didn't update the docs & the checking code behing the "test connection' button or the release notes to indicate the changed requirement.

    I've found a number of other minor bugs I won't go into here (things like UI formatting, no actual issue with functionality) many of which date back to VSA 6.xx. Kaseya's lack of detail on such things is astounding. NB: all the above are ticketed and have been open a week or more with Kaseya; no solutions in sight.

    Heck, they couldn't even get the link on the system page to the patch release notes right on release (It's updated now, but was broken initially).

    I'm on patch 9.0.0.4.

    I could go on and on about required changes e.g. UI consistency across modules, but then i'd be writing page after page after page. What I will say, is that I have no faith in the "Feature Requests" mechanism ... all too often I raise a ticket for a bug and they just tell me to write it in the feature requests area. If I do so, it's just ignored. So what's the point?

  • Thank you for the feedback Craig.

    I have experienced the KRC connection issues on my R9 test server as well.

    The EMM approach is interesting and I will definitely have to take a more detailed look at the module and its functionality.

  • Hi Craig

    Stumbled across many of the same bugs that you've listed and am sitting head in hands as I'd hoped that due to the lack of updates in the core product then it would really be R8+bug fixes, it appears not.  

    I had some success upgrading the agents to fix the RC issue but it appears you need to do this every time you connect which is ridiculous.

    The problem with the views you can get around by editing the view, making a change or not making a change then saving the view and it works again.  I've got views to identify old agents which is where I discovered the problem.

    Luckily this is our internal server but had I installed this on our customer facing servers this would have been a disaster.  "Sorry guys you can only use kvnc as the new super RC is broken unless you upgrade agents and add an extra couple of minutes onto your already busy day."  

    All this in the week that LabTech/Connectwise announce that they're now merged/bought over ScreenConnect which is a tried, tested and trusted RC product.  Makes for interesting conversations this week.

  • Just noticed all the kmdm report parts, report templates etc. are still present in my VSA, despite removal of kmdm in R9.

    For that matter, there doesn't appear to be any reporting at all in EMM in R9. Hmm.

  • Craig - I've noticed the KRC issue as well with the "Machine Not Online" status. Very irritating. I'm getting a trial of Labtech this week...had enough broken promises from Kaseya. The last straw was the delay in getting the BUDR module to actual do what it is supposed to - full synthetic offsite replication. It still doesn't work correctly, and is costing me time and money that Kaseya seems disinterested in fixing. On to the next.

  • cbiggers, So you know, I have had screenconnect for the past six months. No one in our office can use it for more than 3 minutes or less before it disconnects. I have tried from several machines, various versions of Windows and always the same result. We contacted ScreenConnect and tech support connected to a workstation from the outside using our licenses on our server to remote machines and they had no problems for over 5 hours, yet from within our network, not useful at all. They ran network tests and logs but could not identify any issues. I thought we had a winner, but not useful at all if we cannot connect from within our network to client machines. Support gave up telling me it must be something within my network, but could not tell me what the problem might be.

    I strongly recommend you take full advantage of the 30 day trial and test, test, test...

  • Marc - Why aren't you using the built in VNC? Just curious. Just got my demo today, so I am putting it through its paces with my staff...

  • Have you tested the fix for the R9 Remote Control issues?  I seem to have no success when restarting the agent service.

  • Oscar - Nor have I. In fact, it has a tendency to knock the agent offline completely. Rebooting the agent fixes it, which of course, is an absurd workaround.

  • The fix I linked to in my first post doesn't work reliably for me either. In many cases the Kaseya agent service name is different (e.g. "Kaseya Agent #2"), so the batch file fails there; in other cases the service quite simply just doesn't restart.

    The fix I've been using is to just re-install the agent (just like upgrading the agent version; don't forget to tick the force update box), which does work reliably.

  • Built-In VNC, too much overhead if you need to connect to multiple clients at the same time.

  • Craig, did you insert your agent name in the batch file between the quotes? Your agent name is the service name starting with KAxxxxx or if you have an agent on your workstation, it's the folder name under c:\Program Files(x86)\Kaseya\xxxxxxxx with KA appended to the name as the service.

  • I was considering upgrading to R9 but waiting for one of these review threads to appear. After reading the everything currently posted, I am hesitant to do this.

    I am wondering if anyone has had minimal issues with the upgrade process and general usability of the update.

    I have a number of tickets that had been open for more than 4 months for issues on my current VSA R7. They recently closed all of them saying that the issue had been fixed in R9 and that I would have to upgrade to resolve the issues. I thought that My version was still in support...

    KRC is constantly used by my call support staff and if it is as buggy as this is sounding I can't justify upgrading until these issues get worked out. I see that the support article you posted has been updated and it has supposedly been resolved as of 9.0.0.5. I was wondering if this fixed these issues for you guys.

    If the views are broken or at least not working as they are intended, how can I trust reports/agent procedures/policy management to run and feel confident that I am capturing all the endpoints?

    Any more information would be greatly appreciated.

  • OK so i'm now on patch 9.0.0.5. The KRC 'machine offline' bug is fixed, and I swear KRC is faster now. There is a new agent version 9.0.0.2 and a new KRC client to install.

    Views are still messed up, no further word on my P0 support ticket, now open 17 days and counting.

    Matt. s - i'd upgrade to at least R9 if I was you...the bugs in 7 are horrible and 9 fixes so many KRC issues - if you can tolerate views being broken for the moment at least. PS version 7 being 2 versions old isn't supported; support is on an N-1 basis, so R9 and R8 are supported only.

    marcb - I was using the display name, not the service name, which was how Kaseya supplied it. In any case the workaround notes now reflect the fixes in 9.0.0.5 so the issue is now moot.

  • Yesterday I installed Patch 9.0.0.5 which now appears (1 day later) to have fixed the KRC connection issues. Naturally, we had to rerun Agent update and force the new version of agents which is 9.0.0.2 but having done that, it appears the connection issue has been resolved.

    I will update further if this is not the case and the problem re-emerges.