Kaseya Community

Kaseya Monitoring Time machine

  • Hello, 

    I am attempting to monitor time machine backups on OS X 10.10 machines.  I have written a script and having difficulty getting the results I am looking for.  The script uses a syslog command to pull the data to a .txt.

    When I run it on the local machine, it runs as expected.  If I send it through the script, it will return ass successful, but it will not enter data in the .txt file, hence will return bad results.

    the command I am using is:

    syslog -f `$Time $Message` -E safe -k Time ge -24h | grep backupd >> /var/tmp/TimeMachineLogs.txt

     

    The Script looks like:

     

     

    Any advice?

     

    Thanks,  John

  • Hi John,

    Can you log a support ticket for this and add the ticket number to this discussion?  

    Regards,

    Robert

  • Have you tried writing the command out, saving it as a bash file and executing it via executeShellCommand?

    just curious to see the results

  • Ticket # 59057

  • Will try as a shell script when I get a chance.

  • Flavio, It does work correctly if I save as a BASH script to the machine, and execute the script on the machine with the kaseya procedure.  My guess is that the procedure scripting language isn't passing the commands correctly, or there is a problem with "escape" characters.  

  • Those single quotes look accented, maybe that's the issue?  This works for us in a procedure:

    syslog -F '$Time $Message \n' -E safe -k Sender com.apple.backupd -k Time ge -24h >>/var/tmp/TimeMachineLogs.txt

  • Interesting.  I have attempted it both ways.  As well as your exact CLI.  It makes the file on the client machine, but the file is always blank, thus will always show a failure.  What OS X versions are you sending against?

  • Ok, So I tried this another more kludgy way, and wrote a short script.  Using the Agent Procedure to write the file to the Mac, then executing the script.

    It works if I make the file on the mac, and run chmod 700 on it to make it execute, then use an agent procedure to execute that script.  BUT if I write the file with the agent procedure, I can't execute it because it doesn't have the executable permission.  How can I either write the file with the executable permission, or send a sudo chmod 700 to change it after it is written?

  • It can write to the file on ours, our user is an Administrator.  Mountain Lion.

  • Yes, I am using an administrator account, as well as have the correct agent credentials set.

  • : were you able to get this working?  I'm very interested in monitoring Time Machine backups via Kaseya.  I saw this was just released to notify via email: https://tmnotifier.com but I'd rather have it built into Kaseya.  Thanks