Kaseya Community

Problem with Symantec Backup Exec Management Plug-in for Kaseya

  • Hello. For those of you running the Symantec Backup Exec Management Plug-in for Kaseya, I am wondering if you ever ran into this issue.  The problem seems to be occuring on about 20 of our managed servers. We have another ~70 servers that seem to be working fine.

    I ran the Agent Procedure to install the Plug-In, and it shows it completed successfully. But the Discovered Machines tab in the Symantec Backup Exec module still shows the message that the PlugIn needs to be installed.

    I connected to one of the problem servers, and browsed to the C:\Documents and Settings\All Users\Application Data\Symantec\Backup Exec Management Plug-in for Kaseya\Logs folder (got the folder name by lookint at the Agent procedure for installing the log in.  I found 3 files.

    - BEKaseyaAgentInstallMsi.log
    - BEKaseyaAgentSetup.log
    - errors.xml

    The BEKaseyaAgentSetup.log file shows the following:
    =============================================
    04:15:2012 07:54 :Installation Started
    04:15:2012 07:54 :WARNING: Failed to remove C:\Documents and Settings\All Users\Application Data\Symantec\Backup Exec Management Plug-in for Kaseya\Logs\errors.xml due to error 2
    04:15:2012 07:54 :Verifying if the user has administrator rights on the computer.
    04:15:2012 07:54 :New version of Agent for Backup Exec Agent Plugin: 1.0.143.0.
    04:15:2012 07:54 :Starting BEKaseyaAgent MSI - Regular Install Mode
    04:15:2012 07:54 :msiexec /i "BEKaseyaAgent.msi" /qn REBOOT=ReallySuppress /l*v+ "C:\Documents and Settings\All Users\Application Data\Symantec\Backup Exec Management Plug-in for Kaseya\Logs\BEKaseyaAgentInstallMsi.log"
    04:15:2012 07:54 :Msiexec Return Code 1603
    04:15:2012 07:54 :Regular Install Mode - Agent installation failed. Run command 'net helpmsg 1603' for more information about this error.
    04:15:2012 07:54 :Done writing Errors.xml.
    04:15:2012 07:54 :Installation finished
    =============================================

    The errors.xml file shows the following:
    =============================================
    - <?xml version="1.0" ?>
    - <agentinfo agentid="57763649586363773128433663" version="1.0.143.0" time="2012-04-15 11:54:14">
    - <errors infotype="errors" action="insert">
    - <error>
      <id>0b2a6d79-b21b-4e6d-83b5-6f21bb7e2a62</id>
      <eventtime>2012-04-15 11:54:14</eventtime>
      <severity>3</severity>
      <errorcode>EABA0001</errorcode>
    - <ceddetails>
    - <![CDATA[ <ced>
    <product>beplgnka</product>
    <version>1.0.143.0</version>
    <module>mspbek-agtplugin</module>
    <language>en</language>
    <build>retail</build>
    </ced>
      ]]>
      </ceddetails>
    - <message>
    - <![CDATA[ 1603 - Regular Install Mode - Agent installation failed. Run command 'net helpmsg 1603' for more information about this error.
      ]]>
      </message>
    - <details>
    - <![CDATA[ 
      ]]>
      </details>
      </error>
      </errors>
      </agentinfo>
    =============================================


    When I run 'net helpmsg 1603' at a command prompt, the message "fatal error during installation" is shown. Not too much help there.

    This specific server is running SBS2003. A few of the other problem servers are also running SBS2003, but some are running regular Windows Server 2008. We have about 20 problem servers in total. The plug in is successfully running on other servers running SBS2003, SBS2008, Windows Server 2003 and Windows Server 2008 servers.

    Any idea what is preventing the installation?

    Thanks very much, in advance.

    Lloyd

     

  • Hi Lloyd,

    Can you please share the following details that would allow us to understand the root cause of the issue you are facing with agent plug-in's installation and suggest any resolution if possible?

    1. Share the BEKaseyaAgentInstallMsi.log file from the machine where this failure is seen.

    2. Are the machines where installation failure is encountered, running under ENGLISH version of OS or by any chance, are they running under non-English OS? In case of non-English OS, provide the language list that failure is seen.

    3. Can you try re-running the same agent procedure to install the agent plug-in? Let us know the result of this step.

    4. Can you pick two SBS2003 servers where agent plug-in installation succeeded on one & failed on the other and then compare the Service Pack/HF levels between them? Please share the OS SP level details of both servers.

    Regards,
    Ramesh Bupathy
    Symantec Corporation

  • SBS2003-BEKaseyaAgentInstallMsi.log

    Ramesh,

    Thanks very much for the reply. Here is some more information:

    1. Attached is a sample BEKaseyaAgentInstallMsi.log files, from a server running SBS2003.

    2. Upon further review, I would say the majority of the machines that are failing are running SBS2003. There were other SBS2003 servers that were successful. And some machines that failed are running Server 2003 (non-SBS) as well as Windows Server 2008. But the vast majority of the servers experiencing the problem are running SBS2003.

    3. All servers are running ENGLISH edition of Windows.

    4. As you can see from the attached log files, re-running the agent procedure to install the plugin resulted in the same error.

    5. In the BEKaseyaAgentInstallMsi.log file, I noticed the text “Symantec Backup Exec(TM) version 10.0. is not supported. Please install a supported version of Symantec Backup Exec.”  But I can tell you for sure that this server is running Backup Exec v2010 R3 (Servicer Pack2). I checked two other problem servers, and found the same message in the BEKaseyaAgentInstallMsi.log file for those servers, but I am also sure those servers are running v2010.  I can also report that Backup Exec 2010 is shown in the Backup Exec column on the Discovered Machines window on the Backup Exec tab in Kaseya.

    6. I can tell you that these servers have been around for years, and would have had prior versions of Backup Exec installed in the past, but have since been upgraded.

    Any ideas on what to do next?

    Lloyd

  • Hi Lloyd,

    Thanks a lot for sharing all the required information.

    It seems agent plug-in installer does find multiple reg key entries under "HKLM\Software\Symantec\Backup Exec\" hive. Under this registry hive, a registry key that reads as "13.0" (or "12.5" etc.) is expected. Since this server had Backup Exec v10.0 and then upgraded to later versions up to 2010 R3 (SP2), there is a possibility that the older registry keys (such as "10.0" or "11.0" etc.) might have been left behind. I guess that the agent plug-in installer might be always reading the very first registry key (in your case "10.0") and comparing with the list of supported versions (i.e. 12.5 and 13.0). Note that 13.0 refers to 2010 R2/R3 releases.

    Can you please share a screenshot of the  "HKLM\Software\Symantec\Backup Exec\" registry hive by expanding this node? We would like to know all the sub-keys exist under this hive.

    Additionally, if you find that the above is the case in your setup, you may consider renaming the "10.0" registry key to beyond 13.0 (may be "100.0" or so). If you find "11.0" or "12.0" keys, you may need to rename them as well to beyond 13.0 (may be "110.0" and "120.0" or so). Now, run the agent procedure to install the agent plug-in and see it succeeds.

    Note that I am not sure whether those older reg keys have any significance for Backup Exec 2010 R2/R3 product's functionalities, otherwise those legacy keys be just removed. So, it is better if you can rename those keys back to its original name once agent plug-in installation is completed successfully. If needed take a backup of this registry hive before modifying.

    Thanks for co-operating with us.

    Regards,
    Ramesh Bupathy
    Symantec Corporation



    [edited by: symantec_corp at 12:16 PM (GMT -7) on 4-17-2012] Corrected text.
  • Ramesh,

    Attached is a screen capture of the HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec registry hive, taken from the Registry Editor Live Connect window.

    - I renamed the 9.1 hive to x9.1

    - I renamed the 10.0 hive to x10.0

    - I re-ran the Agent Procedure to install the PlugIn. This time this BEKaseyaAgentSetup.log file shows "Regular Install Mode - Installation completed successfully."

    So I think we have identified the problem - which seems to occur whenever there are peices of registry keys left over from prior versions/installations of Backup Exec.

    So here is my question to Symantec.... the Backup Exec column on the Discovered Machines window on the Backup Exec tab in Kaseya correctlyshows the currently installed version of the Backup Exec software. So somehow, it knows the magic way to tell which version is really installed.  Is there any way we can get the installation file for the PlugIn to also be able to detect that version, and only look for those registry keys, and ignore the other registry keys from prior versions?

    Thanks for the help.

    Lloyd

  • BackupExec-Capture.JPG

    sorry, I forgot the screen capture, here it is.

    The remaining registry key was 13.0

    Lloyd

  • Lloyd,

    Let us plan for having a fix for this issue. We will get back here soon. Thanks for your co-operation and patience!

    Btw, Discovered Machines UI would be showing the Backup Exec versions correctly because that information is shown from the data collected by Kaseya's AUDIT task. Kaseya pulls this information from a different registry hive that corresponds to where Add/remove programs list information exists and not from "HKLM\Software\Symantec\Backup Exec for Windows\Backup Exec".

    Regards,
    Ramesh Bupathy
    Symantec Corporation



    [edited by: symantec_corp at 12:47 AM (GMT -7) on 4-18-2012] Added discovered machines related comment
  • Ramesh,

    Thanks very much for the reply.  A follow-up question...

    Would you say a fix for the issue would be a week or two or three away?  Or more like several months?  The reason I ask.... we have about 20 servers with this problem. If the fix is just a week or two away, I will wait for it.  But if its more likely to be several months, then we might just proceed with manually editing the registry in order to proceed with getting the module to work. Its 20 servers, but we could probably do the manual fix in just an hour, so its not a terrible workaround if we have to go that route.

    If its not too much of an imposition, could you please also look at my last post to this other thread regarding the Backup Exec PlugIn? Thanks!

    community.kaseya.com/.../14276.aspx

    Thanks for your help!

    Lloyd

  • Hi Lloyd,

    I could tell you that engineering is already actively working on a fix to this issue. But, to get a hotfix/quickfix for plugin v1.0, I suggest you to get a support case opened with Symantec technical support and rest all will follow.

    Regards,
    Ramesh Bupathy
    Symantec Corporation

  • Do we have a fix for this?

  • @GConnors: If you are facing the same issue as discussed in this thread (73375), here is the update:

    The fix has been included in v1.1 plug-in release which will be available for customers in couple of weeks as part of First Availability (FA) program. You have to sign up for getting the v1.1 plug-in early through FA program. If you wish to get the issue addressed by upgrading your current v1.0 to v1.1 plug-in, let me know. We can have you signed up in the FA program by contacting you.

    Regards,
    Ramesh Bupathy
    Symantec Corporation

  • Hi Ramesh. Thanks for your help here. It's very refreshing to have that kind of support. I would like to be included in the First Availability (FA) program for this plug-in, please.

  • Hi GConnors and Zippo,

    Can you please visit  symbeta.symantec.com/login.html  and register yourself? This is the Symantec's Beta & First Availability (FA) registration portal. Once you are registered, you will be receiving further information directly from our Beta & FA program team. Let us know if you need any help in this regard.

    Regards,
    Ramesh Bupathy
    Symantec Corporation

  • Thanks, Ramesh. I'm logged in but all I see is the Symantec Endpoint Protection Plug-in - not the Backup Exec Plug-in. How do I add it?

  • I don't see any products in my symbeta portal.