Kaseya Community

K2 6.1 and RDP fails

  • Hi,

    I too just upgraded from 6.0.1 to 6.1. The upgrade itself was fairly painless but now our remote controls... suck. And here are some ways in which they do.

    • Full screen RDP sessions on dual monitor workstations cause havoc. The left half of the RDP window is black; the screen "begins" at half window. It's like you'd take a full screen RDP session and shifted the viewport half a monitor. The session on the other side also seems to tall to fit the window. This needs more investigation.
    • Full screen RDP session when "restored" (click the icon with two window-like boxes) terminates the session, just like that. In 6.0.1 it would embed the screen into the Live Connect page.
    • I still can't configure the embedded screen size to be bigger.
    • Oh, and K2 6.1 seems even more crash prone than 6.0.1

    Is there anything i can do but reinstall 6.0.1 and use the backups, before they get deleted...?

     ~rL

  • I've created a tickets for the first two.

    Nr 2 is confirmed and going to be hotfixed.

    I just reported Nr 1. Still waiting on feedback. Guessing that will be hotfixed too. I noticed that the dual screen error only happens in Win XP - with RDP 7. RDP 6 has no problems. Also Win 7 seems to work fine.

    Firefox also seem to work more steady with KLC (less crashes) then IE 8.

  • Bzzzt! I use Windows 7 with whatever RDP client comes with it. And i get the screen alignment problem.

    As a workaround, i opened up the Remote Control module for my techies. Which brings me to another problem (that i really should put into another thread).

    In the Remote Control module, when opening up a fixed size RDP client, it always opens in the top left of the screen. If i move the window, it is "restored" to a smaller size. If i press the Restore button to get the window to full size, it aligns back to the top left of the screen. The only way i can think of to have the RDP window anywhere else than the top left of the screen is move it, then resize the window from the corner of the window.

    Did that make any sense to you?

    I'll try KLC with Another Browser. It Just Might Work.

     ~rL <-- slightly annoyed with the bugs in K6.1

  • I am also slightly annoyed with the upgrade too. I get a crazy IIS/SQL error that I used to create a ticket with support every time I try using rdp or vnc from LiveConnect, still no word on what is causing it.

  • Ok, after getting the latest hotfix for today (Feb 8th) I was able to apply that, reapply the schema and it seems to be working now. I am going to keep my ticket open just to see what they say, but either the hotfix, schema reapply, or combination fixed it up. Working in IE8 and Chrome respectively (after DLing the control)