Kaseya Community

KNM not recognizing Esxi CIM account credentials

This question is not answered


   I am trying to setup VMware disk health monitors, only about 20% of the ESXI boxes were are monitoring with KNM seem to be reporting properly the rest keep giving me "401 Unauthorized - username or password wrong." I know the password is right and i can login to the host. I can even create new credentials with CIM only access update it in KNM Agent/Org credentials, but still nothing.

 This affects just the LUA script monitor for disk health monitoring all other monitors seem to be working fine. Any leads or anyone experience this?



All Replies
  • Hi  

    Out of curiosity, do you have both the CIM Credentials and VMWare credentials implemented on the object/asset?

    You will require both in place to monitor fully ESXi functions.

    If this is in place, can you clarify what build of KNM you are running and what version of ESXi you are trying to monitor?

    You mentioned you have this in place on several ESXi boxes, but only 20% are affected, do these boxes have anything in common? (ESXi version?)

    Additionally, have you created a support ticket on this issue? If yes, please let me know the ticket number.

  • Thanks for you input yes I have both VMWare and CIM credentials setup also turned of inheritance just incase that was the issue but still no luck. I said the Health LUA script  is only working on about 20% of the Esxi boxes we have tried so far. There is no connection in common works on Vsphere 5.1/Esxi 5.1 at one group but not the other. One thing I did notice it that is not working on any of the VMWare Esxi 5.5 Servers.

    I have a ticket for this #100876

    KNM version 9.1 Build 152084440

  • I've found in the past that this only worked if the CIM permissions for the username in question were explicitly set on each host, as opposed to done as a generalisation in vcenter. - I'm going on some hazy memories, but even with Root it didn't work until we went on and manually allowed the appropriate permissions (and turned on CIM etc) for each host in turn. It was a real pain.

  • I have similar problems, I would say around 70-80% work (50ish ESXi hosts).  I've had a few tickets open about it and we haven't been able to get to the bottom of it.  Not being able to count on the ESX monitoring side for hardware really causes us a lot of problems.  I've been through all the things listed below as well and still unable to get consistent results.  I have a feeling it's related to ESXi versions.

    What are other people doing to monitor ESXi hosts hardware (failed drives mostly)?

  • The key factor here is, that this is a LUA Script that is being implemented.

    If you implement a regular CIM Monitor in KNM (Not a LUA script) does it run correctly?

    The following article was provided to  by our development team in regards to the issue:


    Were you ever able to follow up with this?

    As this issue may be isolated to specific hardware types (machines) that are running ESXi. (The article advises to install .VIB files)

    At any rate, if you are still experiencing this issue - please create a support ticket so we can get to the bottom of it.

  • Hi Nicolas,

    link not working.


  • Hello Nicolas, the article is great but it does not seem to address the issue we are having. All the ESXi boxes in questions are reporting hardware configurations properly and alerts. Like I said other monitors works fine Like the Datastore disk usage and Performance monitor, it is just the LUA script that keeps failing on login.

  • I think we finally figured it out.

    Add VMWAREand CIM account to top level authentication and then Enable Inherit Credentials to all Monitors.

    I added the CIM permissions explicitly to each Host, thanks for the suggestion, and then set the threshold settings user ID/password to match the VMWARE root account on the CIM monitor settings.

    So far so Good. New devices added to KNM ...

  • I finally got it sorted see Phil G's suggestion and then I enabled inherit Credentials so the CIM/VMware credentials flow down.

    I hope this gets you to 100%