Kaseya Community

Mail from Kaseya about upgrade delay, but already upgraded......

  • Hi I got a mail from Kaseya that the upgrade from version 8 to version 9 is delayed because an issue that could impact customers.

    They write they are busy writing a patch and then will enable us to uprgade in the week of 2nd of march.

    However, we where already enabled last week, I waited until patch 5 was out because of the issues I read about.

    I upgraded on Monday evening, the installation failed at the end during schema application. I did a reaplly of the schemas that gave the same problem.

    Doing a reinstallation (without removing kaseya offcourse) of the upgrade however worked flawless.

    After that no problems what so ever, not the nightmare we had going over to version 8, no more KRC disconnections issues, pages not working.

    Everyhing working just great and snappier.

    However this email puzzles me, I can't write back or respond to kaseya because it's a noreply address, everything is working so I can't put in a ticket.

    I would like to know what the issue is they are talking about, and am also wondering why they didn't register that we've already upgraded fine ?

    Hoping somebody from Kaseya will respond.

  • During the initial phases of the rollout, we identified an issue that could impact customers running in certain environments.  This issue, along with several other items ,were resolved in Patch 9.0.0.5 and Patch 9.0.0.6 (released today).  As you know, for several weeks after the release, we manage R9 on-premises downloads to ensure support resources are available for those who need them.  We've adjusted the rollout schedule so those who were waiting on the patches can upgrade.

    As for why you received the notification, but had already upgraded.  We decided to be conservative and send it to anyone who registered for the R9 upgrade, but had not yet been sent an email that their upgrade was available.

  • Thank you Mike for explaining that.

    We did get a mail we where scheduled for upgrade last week, but we didn't know you will send a mail that it's ready.

    So we just tried and saw in that week that we could install. We delayed until 9.0.0.5 was out and got comments that major problems where fixed.

    Kind regards, Erik.

  • I got the same email, despite being one of the very first on 9.0.0.0 and been reporting bugs and working with top level support for weeks now....i'm the guy that found [most of] the bugs that were fixed in 9.0.0.5 and 9.0.0.6.

    I imagine the mailout just came off an automated list that they prepared back in January, and it hasn't been edited to remove those on R9 already. No big deal but just looks slightly unprofessional.

  • The error they might be referring to is in the install script the rebuilds the database maps. If you go to your SQL Server, Management Studio and click on ksubscribers database and execute this command: execute hermes.dscBuildObjectMap and let it run, your premise VSA server will be just fine.

    The xml file is on your kserver called map.xml. The line that is failing is <File ObjType="script" ObjName="BuildObjectMap" ResponseTimeOutSeconds="7200">script\BuildObjectMap.sql</File>

    Remark this line when installing patches or upgrades at this time. After your install completes, run the execute hermes line I mentioned in the first paragraph